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Abstract

Objective of the monograph is twofold. First, it is a user guide for COMSOL
Multiphysics 3.3 modeling for 3D undersea acoustics and accurately evaluating the
scattering from elastic targets. Second, we develop a code that couples the near-field
COMSOL modeling and the fast far-field Fortran solver to evaluate the scattered
field with hundreds of wavelength. It is based on an iterative method based on the
domain decomposition/embedding method and enables us to evaluate the scattered
field for higher frequencies 15-20 kHz. In this frequency range millions of unknowns
are required for the finite element modeling.

1 Model problem

The physical problem is the scattering of a wave by an solid elastic cylinder buried in a

sediment under the water. It is an exterior problem which have to be truncated into a

bounded domain for a finite element discretization. We use a truncation to a rectangular

domain. It is shown in Fig. 1.

The partial differential equation model for the pressure p in water and sediment (Π\Ω)
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Figure 1: Computational domain.

and the displacement u in the elastic object (Ω) is:

∇ · 1

ρ
∇p +

k2

ρ
p + g = 0 in Π \ Ω

1

ρ

∂p

∂n
= ω2u · n, −pn = σ(u)n on ∂Ω

∇ · σ(u) + ω2ρu = 0 in Ω

Bp = 0 on ∂Π,

(1.1)

where ρ is the density, ω is the angular frequency, k = ω/c is the wavenumber, c is the

speed of sound and σ is the stress tensor. f is a time-harmonic forcing term and n is the

outward unit normal.

We pose an absorbing boundary condition Bp = 0 on ∂Π. Most often we employ

the second-order absorbing boundary condition which usually leads to sufficiently small

reflections from the boundaries for practical purposes. The boundary ∂Π consists of six

rectangular faces, denotes by Γ±k, k = 1, 2, 3, whose outward normal directions are given

by the coordinate directions ±xk. The second-order absorbing boundary conditions on

these faces are of the form

± ∂p

∂xk

− ikp− i

2k

∑

1≤j 6=k≤3

∂2p

∂x2
j

= 0. (1.2)

Furthermore, we have the conditions

−3

2
k2p− ik(± ∂p

∂xm

± ∂p

∂xj

)− 1

2

∂2p

∂x2
k

= 0 (1.3)

on each edge denoted by Γ(±m,±j) between the faces Γ±m and Γ±j and the conditions

−2ikp +
3∑

j=1

± ∂p

∂xj

= 0 (1.4)

on the eight corners denoted by Ψ of the parallelepiped.
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We will describe how to use the COMSOL Multiphysics 3.3/ Structural Acoustic Mod-

ule to evaluate the scattered field from the elastic target in Section 2. For the large

frequency, the large memory is required and COMSOL cannot solve it directly. We de-

scribe a coupled code in Section 3 to solve (1.1) for larger frequencies. The problem was

solved by an iterative method that utilizes COMSOL code in a small box surrounding the

target (near filed) and a Fortran code outside the box (far field).

2 Finite-element analysis with COMSOL

In this section, we describe in detail the COMSOL coding for the 3-D time-Harmonic

structural acoustic problem (1.1).

For the acoustic system, COMSOL solves the following equation

1

ω2
∇ · 1

ρ
∇p +

1

ω2

k2

ρ
p +

1

ω2
g = 0, (2.1)

which is a Helmholtz equation by multiplying the first equation in (1.1) with 1/ω2. From

(2.1) and (1.2)-(1.4), we have the weak formulation: Find

p ∈ V = {v ∈ H1(Π \ Ω) : v|∂Π ∈ H1(∂Π), v|Γ(m,j)
∈ H1(Γ(m,j)),∀Γ(m,j) ∈ Φ}

such that
∫

Π\Ω

1

ρω2
(−∇p · ∇q + k2pq)dx + ik

∫

∂Π

1

ρω2
pqds

− i

ω2

3∑

k=1

∑

j 6=k

(∫

Γk

1

ρω2

∂p

∂xj

∂q

∂xj

ds +

∫

Γ−k

1

ρω2

∂p

∂xj

∂q

∂xj

ds

)

−3

4

∑
Γ(m,j)∈Φ

∫

Γ(m,j)

1

ρω2
pqdl +

1

4ω2

∑
Γ(m,j)∈Φ

∫

Γ(m,j)

1

ρω2

∂p

∂xk

∂q

∂xk

|k 6=m,jdl

− i

2ω

∑
x∈Ψ

1

ρω2
p(x)q(x) +

1

ω2

∫

Π\Ω
gqdx = 0.

(2.2)

Here Φ is the set of all edges of ∂Π.

2.1 Starting COMSOL Multiphysics

We solve the two problems of with and without the elastic target simultaneously for the

ease of postprocessing, e.g., evaluating the scatter field. Open COMSOL Multiphysics 3.3.

In the Model Navigator window Fig. 2, we define the Multiphysics model for our problem

as follows.
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• Click Mutiphysics.

• Click Add Geometry. Choose 3D for Space dimension in the pop-up Add Geometry

window and click OK. Then we have added a 3D geometry (Geom1).

• Click Add Geometry. Choose 2D for Space dimension in the pop-up Add Geometry

window and click OK. Then we have added a 2D geometry (Geom2).

• Click the icon ’Geom1(3D)’ in the small window on the right, and then in the

large window on the left, under Application Modes, select COMSOL Multiphysics

> Acoustic > Acoustics, click Time-harmonic analysis. In Element (bottom left

corner), select Lagrange-Linear and click Add (top of the right window). Now we

have one acoustic system ’aco’.

• Click the icon ’Geom1(3D)’ in the small window on the right, and then in the

large window on the left, under Application Modes, select COMSOL Multiphysics

> Structural Mechanics Module > Solid, Stress-Strain, click Frequency response

analysis. In Element, select Lagrange-Linear and in Dependent variables, change

the variables to ’u,v,w,p2’, then click Add. Now we have the structural mechanics

module ’smsld’.

• Click the icon ’Geom1(3D)’ in the small window on the right, and then in the

large window on the left, under Application Modes, select COMSOL Multiphysics >

Acoustic > Acoustics, click Time-harmonic analysis. In Element, select Lagrange-

Linear and click Add. Now we have one acoustic system ’aco2’.

• Click OK on the Model Navigator window.

We now have COMSOL Multiphysics window.

Remark: Of course, we can solve the both problems separately. In fact we only solve

the problem with target alone for the coupled code in Section 3, i.e, we only solve the

system with ’aco’ and ’smsld’.

2.2 Material properties definition

First, we define the material properties of the water and the sediment by

• Click the COMSOL menu Options > Constants, and fill Constants window as Fig. 3.

Secondly, we define the application scalar variables by

• Click the COMSOL menu Physics > Scalar Variables, just change the frequency in

the Application Scalar Variables window as Fig. 4.
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Figure 2: Model Navigator.

Then COMSOL automatically defines c, ω and k as:

cs aco=c1 or c2 (depend on the different subdomains),

omega aco=2*pi*freq aco,

k aco=omega aco/cs aco.

2.3 Geometry

In the COMSOL Multiphysics window, first we need define a 2D working plane, and then

we extrude it to the 3D geometry. The 2D geometry is defined as follows.

• Select ’Geom2’ from the two tabs ’Geom1’ and ’Geom2’.

• Click Draw > Specify Objects > Rectangular, and on the pop-up window specify

the box as in Fig. 5 and click OK (as a result we have Box R1).

• Click Draw > Specify Objects > Rectangular and on the pop-up window (just like

the Fig. 5) specify the box. We just change the Width and Height and the Position

in the window. Click OK (as a result we have Box R2).

• Click Draw > Draw Objects > 2nd Degree Bezier Curve and click at the point (-

2.2625,0.4354) and connect to the second point (-2.075,0.5354) ,click at the point.

Then connect to the third point (-1.8875,0.4354), click. Right click to finish a curve

(as a result we have a domain CO1). Click Copy symbol on the menu to copy CO1.

Click CO1 and press Ctrl key, then click R2 (now we selected the two domains). Click
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Figure 3: Constants.

Figure 4: Model Navigator.

the vertical menu Union and click the third icon from the bottom of the vertical menu

Delete interior boundaries, click Paste symbol on the menu and click OK (as a result

we have domain CO2). Click CO2 and press Ctrl, then click R1. Click Difference

icon on the vertical menu (as a result we have two subdomains CO3 and CO1).

• Click Draw > Draw Objects > 2nd Degree Bezier Curve and click at the point (-

1.8875,0.4354) and connect to the second point (-1.7,0.3354), click at the point. Then

connect to the third point (-1.5125,0.4354),click. Right click to finish a curve (as a

result we have a domain CO2). Click Copy symbol on the menu to copy CO2. Click

CO2 and press Ctrl key, then click CO3 (now we selected the two domains). Click

the vertical menu Union and click the third icon from the bottom of the vertical

menu Delete interior boundaries, click Paste symbol on the menu and click OK (as

a result we have domain CO3). Click CO3 and press Ctrl key, then click CO1. Click

Difference icon on the vertical menu (as a result we have two subdomains CO2 and
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CO4). Now we have two subdomains CO2 and CO4 with one wave of the wavy

interface.

• Click Draw > Specify Objects > Square and on the pop-up window specify the left

top corner box as in Fig. 6. Click OK (as a result we have a box R1). The coordinate

of the right lower corner of ’R1’ is (−10, 4.4354) in the 2D working plane (we wish

that the source point (−10, 4.4354, 0.25) is located on a mesh point, so we define

’R1’.)

• Click R1, Click Copy, press Ctrl key and click CO2, click Difference Icon, click Paste

and then OK (as a result we have R1, CO1, CO4).

• Click Draw > Specify Objects > Circle and on the pop-up window specify the circle

as in Fig. 7. Click OK (as a result we have target cylinder C1).

• Click C1, Click Copy, press Ctrl key and Click CO4, Click Difference Icon, click

Paste and then OK (as a result we have R1, CO1, CO2, E1).

In order to have the wavy interface, we need to repeat the two steps 4 and 5 at different

points. After the wavy interface is done, we have completed the 2D working plane as

shown in Fig. 8.

Then we extrude the 2D geometry to 3D geometry by doing the following steps.

• Click Draw > Extrude > Select all objects CO1, CO2, R1 and E1 and and specify

the distance (0.25) and click OK (as a result temporary 3D geometry).

• Click Cut symbol to cut this temporary 3D geometry. Click Paste symbol, in the

pop-up window, change the Displacements on z to -0.25. Click OK.

• Click Paste symbol, in the pop-up window, change the Displacements on z to 0.5.

Click OK.

• Click Draw > Extrude > Select all objects CO1, CO2, R1 and E1 and and specify

the distance (0.5) and click OK.

Now we have the 3D geometry Fig. 9.

2.4 Mesh

For the large domain computation, we prefer not to use the tetrahedral mesh. It will have

more freedoms than prism mesh with the same mesh size. For a 1500 frequency, we need

the mesh size smaller than 0.1m. Now we will construct a prism mesh on the 3D geometry

Fig. 9.
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Figure 5: Rectangular defining.

Figure 6: Corner box defining.

• Select ’geom1’ from the two tab ’geom1’ and ’geom2’.

• Click COMSOL menu Mesh > Free mesh parameters. Select ’boundary’ tab in the

pop-up Free Mesh Parameters window.

• Select all the faces on the front x-y plane of the 3D geometry. Type in 0.1 in the

Maximum element size.

• Click the Mesh Selected button, we obtain a triangular mesh distribution on this

face.

• Click the COMSOL menu Mesh > Swept mesh parameters. In the pop-up window,

select the subdomain 3 from the Subdomain selection window on the left. Select

the Element Layers tab, check Manual specification of element layers and Number

of element layers, and type in 5. Select Sweep Direction, check Manual specification
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Figure 7: Cylinder target defining.

Figure 8: Cross section of the 3D geometry.

of sweep direction. Type in 10 in the source face and 9 in the target source. Click

Mesh Selected. Then we have the prism mesh distribution in the subdomain 3.

• Repeat the step 5 in each subdomain from the front to the behind.

Finally, we obtain a 3D mesh distribution for the whole domain. See Fig. 10.

2.5 Subdomain settings

For the subdomain settings, first we set up for the acoustic part.

• Select Mutiphysics > Acoustic (aco), and click Physics > Subdomain settings.

• Select subdomain for the elastic target, and uncheck ’Active in this subdomain’.

• Select all the other subdomains, on the Physics Tab, enter corresponding ρ0 (with

rho1,rho2), cs (with c1,c2), qs (with 0,0,0) and Q (with 0 for the subdomains without

source, with
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Figure 9: The 3D geometry.

Figure 10: Mesh.

’sech(40*sqrt((x+10)∧2+(y-4.4354)∧2+(z-0.25)∧2)∧8)’

for the subdomains with source, which is shown in Fig. 11.

Then for another acoustic system ’aco2’, every setting up is the same as ’aco’ except

that there is no elastic target in this system, i.e., we do not uncheck ’Active in this

subdomain’ in the domain for the cylinder target.

Finally for the elastic target system,

• Select Mutiphysics > Solid, stress-strain (smsld), and click Physics > Subdomain

settings.

• Select all the subdomains for the acoustic part, and uncheck ’Active in this subdo-

main’.
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Figure 11: Subdomain settings for acoustic system.

Figure 12: Subdomain settings for elastic target.

• On the ’Material settings’ tab, click the ’load’ button, and load the ’Aluminum

3003-H18’ model.

Then we have the subdomain settings for the elastic target part as shown in Fig. 12.
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2.6 Interface settings

First, we define the interface condition for the elastic target. This interface condition

couples the acoustic pressure p from acoustic system ’aco’ to the velocity (u, v, w) of

the Structural Mechanics Module ’smsld’. It gives the continuity property of normal

component of stress vector on the interface (the surface between elastic target and the

sediment).

• From COMSOL menu Multiphysics, select Solid, Stress-Strain (smsld). Click COM-

SOL menu Physics > Boundary settings.

• In the pop-up window, select all the boundaries of the elastic target. On the tab

’Constraint’, select ’Free’ for the constraint condition.

• On the tab ’Load’, select ’Global coordinate system’.

• Type in ’-p*nx smsld’ for Fx, ’-p*ny smsld’ for Fy, ’-p*nz smsld’ for Fz.

• Type in 1 for FxAmp, FyAmp,FzAmp.

• Type in 0 for FxPh,FyPh,FzPh.

See Fig. 13.

Secondly, for the acoustics system ’aco’, we need define the continuity property of

normal displacement of p on the interface.

• From COMSOL menu Multiphysics, select Acoustics (aco).

• Click COMSOL menu Physics > Boundary settings. In the pop-up window, select

all the boundaries of the solid target.

• Select ’Normal acceleration’ for the boundary condition.

Type in ’-omega aco∧2*(u*nx smsld+v*ny smsld+w*nz smsld)’ for the ac-

celeration value.

See Fig. 14.

2.7 Boundary settings

We need define the absorbing boundary conditions on the outside boundary ∂Π. Here we

use the second order ABC. We need set up the faces, the edges and the corners on the

boundary.

• For the faces on the boundary, from the COMSOL menu Physics, select Equation System,

and then click Boundary Settings, in the pop-up window, select the tab ’Weak’. And then

type in the weak form for the boundary faces. For example, we choose the boundary faces

on the y-z plane, and then type in

’-(-i*k aco*p*p test +i*(1/(2*k aco))
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Figure 13: Interface condition setting up for elastic target.

Figure 14: Interface condition setting up for acoustic system ’aco’.

*(pTy*test(pTy)+pTz*test(pTz)))/(rho aco*omega aco∧2)’

in the first line of the pop-up six lines. For the sixth line of the pop-up six lines, type in

’-(-i*k aco2*p3*p3 test+i*(1/(2*k aco2))

*(p3Ty*test(p3Ty)+p3Tz*test(p3Tz))) /(rho aco2*omega aco2∧2)’.

See Fig. 15.

• For the edges on the boundaries, from the COMSOL menu Physics, select Equation

System, and then click Edge settings, in the pop-up window, select the tab ’Weak’. And
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Figure 15: Boundary settings for the faces on y-z plane.

then type in the weak form for the boundary edges. For example, we choose the boundary

edges on x-direction, and then type in

’((1/(2*k aco)∧2)*pTx*test(pTx)

-(3.0/4)*p*test(p))/(rho aco*omega aco∧2)’

in the first line of the pop-up six lines. For the sixth line of the pop-up six lines, type in

’((1/(2*k aco2)∧2)*p3Tx*test(p3Tx)

-(3.0/4)*p3*test(p3))/(rho aco2*omega aco2∧2)’.

See Fig. 16.

• For the points at the domain corners, from the COMSOL menu Physics, select Equation

System, and then click Points settings, in the pop-up window, select the tab ’Weak’. And

then type in the weak form

’-(i/(2*k aco))*p*test(p)/(rho aco*omega aco∧2)’

in the first line of the pop-up six lines. For the sixth line of the pop-up six lines, type in

’-(i/(2*k aco2))*p3*test(p3)/(rho aco2*omega aco2∧2)’.

See Fig. 17.

2.8 Solution

COMSOL gives us a wide selection of direct and indirect solvers. For this Time-harmonic

problem, we use the iteration solver ’GMRES’ with the ’Geometric Multigrid’ precondi-

tioner.

• Click the COMSOL menu Solve − > Solver Parameters, from the pop-up window, on

the ’General’ Tab, choose ’Gmres’ for the linear system solver, and ’Geometric Multigrid’
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Figure 16: Boundary settings for the edges on x-direction.

for the preconditioner.

• Click the COMSOL menu Solve − > Solve Problem.

Then the system for the coupled acoustic and elastic system (p, u, v, w, p2) has been

solved. At the same time the acoustic system without the target (p3) also has been

solved.

2.9 Postprocessing

From the COMSOL menu ’Postprocessing’, we can plot the total field (p) or the scatter

field (p-p3). They will plot the real part. If we wish to plot the imagine part or absolute

value, just type in ’imag(p)’ and ’abs(p)’ for the total field, ’imag(p-p3)’ and ’abs(p-

p3)’ for the scatter field. And because it is a 3D problem, if we wish to plot any cross-

section of the 3D domain, just click Postprocessing − > Cross-Section plot parameters. On

the pop-up window, select the ’slice’ tab, select the ’slice plot’ and type in the expression

we wish to plot and also the coordinates for the three points on the plane which we wish

to plot.

3 Coupling of Fortran exterior code and COMSOL

structure acoustic code

With higher frequencies a finite element discretization leads to very large systems of linear

equations. Often two-dimensional problems have millions of unknowns. It might be pos-
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Figure 17: Boundary settings for the points at the domain corners.

sible to solve these problems using a LU factorization with a nested dissection reordering

of unknowns, but this approach cannot be used for three-dimensional problems which can

have billions of unknowns. For this reason, we consider the iterative solution of these

problems. In the right preconditioned GMRES method we employ a domain decomposi-

tion preconditioner based on a domain embedding approach. A sperable preconditioner

based on discretiztion of the perfectly vertically layered without an object is used. We

discretize the time harmonic wave equation using linear finite elements on uniform rect-

angular meshes which are locally adapted to the wavy sediment interface and the surface

of the object. In our solution procedure we employ a domain decomposition in which the

near field subdomain is the interior of the dashed box in Figure 1 and the far field sub-

domain is the rest of the rectangle Π. Since the media is vertically layered with the wavy

interface, our preconditioner coincides with the system matrix except the rows correspond-

ing to unknowns near-by the interfaces. Thus, we can reduce iterations on a small sparse

subspace. This reduction makes our iterative method extremely efficient and enables us

to solve systems with billions of unknowns. Using the domain decomposition the resulting

system of linear equations has the block form

Ax =

(
A11 A12

A21 A22

)(
x1

x2

)
=

(
b1

b2

)
= b, (3.1)

where the first block row corresponds the near field domain inside the dashed box in Figure

1 and the second block row corresponds the rest of Π. The matrix block A11 corresponds

to an elastic object and its near field and it is formed using Comsol Multiphysics software.

The matrix block A22 corresponds to the exterior scattering field discretized via the locally

adapted finite element method. The matrix A has entries with imaginary part and it is
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non-Hermitian. We take an advantage of the following facts. First, due to the small size of

the near field subdomain linear systems with the matrix block A11 is solved by a Comsol

linear equation solver. Second, let C be the corresponding matrix to of the perfectly

vertically layered without an object. The direct inverse method is solve C−1b is developed

in [2,3] and it requires O(NlogN) floating point operations where N is the dimension of

C.

With a right preconditioner B system (3.1) is equivalent to

AB−1v = b. (3.2)

And (3.2) can be written as

v + (A−B)B−1v = b. (3.3)

After solving this system the solution of the original problem is x = B−1v. Here, our

preconditioner has the upper block triangular form

B =

(
A11 A12

0 C22 − C21C
−1
11 C12

)
. (3.4)

Note that C22 − C21C
−1
11 C12 is the Schur complement of C on the second block and thus

(z1, z2) = B−1v is carried out by performing

(∗, z2) = C−1(0, v2)

and then

z1 = A−1
11 (v1 − A12z2).

Now we describe the implement of the algorithm in detail. Hereafter, we use the

different labels for the unknowns, i.e., we let the subscripts 1, 2, and Γ denote the unknowns

on the near-field subdomain, the far-field subdomain, and the interface between them,

respectively. Then the equation (3.1) is equivalent to be written as the following equation:

Ay =




A11 A1Γ

AΓ1 AΓΓ AΓ2

A2Γ A22







y1

yΓ

y2


 =




0

0

f


 ,

where f is due to the acoustic source in the far field domain. The matrix block AΓΓ can

be expressed as a sum

AΓΓ = A
(1)
ΓΓ + A

(2)
ΓΓ,

where A
(1)
ΓΓ and A

(2)
ΓΓ contain the contributions from the near-field subdomain and the

far-field subdomain, respectively. The right preconditioner (3.4) B and the separable

preconditioner C can be written as the following block forms

B =




A11 A1Γ

BΓΓ AΓ2

A2Γ A22


 , C =




C11 C1Γ

CΓ1 A
(2)
ΓΓ AΓ2

A2Γ A22


 .
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We solve (3.3) using the GMRES method and each GMRES iterate we need to perform

multiplications g = v+(A−B)B−1v = AB−1v with changing vectors v which will have the

first block v1 zero. In the first step of the iteration, we let v = b. Then each multiplication

can be done in two steps:

1. Solve

C



∗
yΓ

y2


 =




0

vΓ

v2




using a (partial solution) Fortran code.

2. Solve

A11y1 = −A1ΓyΓ (3.5)

using the Comsol with the Dirichlet boundary condition value yΓ.

It can be shown that only the Γ block of g is non-zero. It is given by

gΓ = AΓ1y1 + AΓΓyΓ + AΓ2y2. (3.6)

Now we describe how to solve (3.5) and how to carry out (3.6). The step (3.5) is done

by Comsol as

fem.sol=femstatic(fem,’solcomp’,’w’,’u’,’p’,’v’,

’outcomp’,’w’,’u’,’p’,’v’,... ’linsolver’,’gmres’,...,’rhob’,1.0,

’prefun’,’gmg’,’mcase’,[0,1]),

where fem.sol is the solution inside Ω along with the boundary value yΓ. Because the

solution is not ordered, in order to compute gΓ, we must perform the following sequence

Comsol calls:

K = assemble(fem,’Out’,{’K’}),

which returns the stiffness matrix K.

[Ke,Le,Null,ud] = femlin(fem),

which returns the matrices Ke and Null which are

Ke = A11 and Ke = NullT KNull,

where the block structure of Null is compatible with the one of K.

Null2’*K*fem.sol.u;

computes

AΓ1y1 + A
(1)
ΓΓyΓ,

and Null2 is the nonzero diagonal blocks of Null*NullT .
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4 Comparison of solutions of Coupled Code and COM-

SOL Code

We compared the solutions of the coupled code and to the COMSOL Multiphysics solution

for a low frequency 1.5 kHz. See Fig. 18 for the comparison for the real and imagine part

plot of the scatter fields. See Fig. 19 for the comparison for the absolute value plot of the

scatter fields.

Figure 18: Real(left) and imagine(right) part of the scatter field from the COMSOL computation(up)
and the coupled code(down).

Figure 19: Absolute value of the scatter field from the COMSOL computation(left) and the coupled
code(right).

And using this coupled code, we also solved (1.1) with frequencies 15 kHz and 20 kHz,

which COMSOL cannot solve it. See Fig. 20 for the absolute value plot of the scatter

fields.

Figure 20: Absolute value of the scatter field from the coupled code with the frequency 15 kHz (left)
and 20 kHz (right).
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